Сообщение о том что нада перезапустить 1с« Вернутся к списку вопросов

Есть компьютер ,на котором всегда запущена 1с. при изменении конфы , на этом компе появляется сообщение о том что нада перезапустить 1с.как это дело автоматизировать?
Сообщение от admin
Ответ на 18.03.2016 20:51
1

Глобальный контекст.КонфигурацияБазыДанныхИзмененаДинамически (Global context.DataBaseConfigurationChangedDynamically)
Глобальный контекст (Global context)
КонфигурацияБазыДанныхИзмененаДинамически (DataBaseConfigurationChangedDynamically)
Синтаксис:

КонфигурацияБазыДанныхИзмененаДинамически()
Возвращаемое значение:

Тип: Булево.
Истина — в процессе работы пользователя с информационной базой произошло обновление конфигурации базы данных, Ложь — в противном случае.
Описание:

Определяет, была ли изменена конфигурация базы данных динамически после старта. Под динамическим изменением понимается такое изменение конфигурации базы данных, при которой не потребовалось проведение реструктуризации, и в момент обновления с информационной базой работали пользователи.

Доступность:

Сервер, толстый клиент, внешнее соединение.
Пример:

// Процедура проверяет факт обновления конфигурации в процессе работы

//
Процедура ПроверкаДинамическогоОбновления() Экспорт
Если КонфигурацияБазыДанныхИзмененаДинамически() Тогда
Сообщить(»Доступно обновление конфигурации!»,
СтатусСообщения.Важное);
Сообщить(»Чтобы обновление вступило в силу, требуется перезапуск!»,
СтатусСообщения.Важное);
КонецЕсли;
КонецПроцедуры

//

Процедура ПриНачалеРаботыСистемы()
ПодключитьОбработчикОжидания(»ПроверкаДинамическогоОбновления»);
КонецПроцедуры

Сообщение от admin
Ответ на 18.03.2016 20:54